ggplot2 - facet_grid - Erreurs dans les graphs ?

Postez ici vos questions, réponses, commentaires ou suggestions - Les sujets seront ultérieurement répartis dans les archives par les modérateurs

Modérateur : Groupe des modérateurs

Oriane Moyne
Messages : 17
Enregistré le : 20 Oct 2015, 15:50

ggplot2 - facet_grid - Erreurs dans les graphs ?

Messagepar Oriane Moyne » 14 Avr 2016, 14:47

Bonjour à tous,

Je fais mes premiers pas avec le package ggplot2, et j'ai l'impression que les graphiques que j'obtiens sont FAUX ! J'aimerai comprendre pourquoi...

Voici un aperçu de mes données :

Code : Tout sélectionner

table(patients$Sexe, 2016-patients$an_naiss)
         
           23 24 27 28 30 31 32 35 36 37 38 39 40 41 43 46 48 50
  Feminin   0  1  2  0  2  1  2  2  1  2  0  1  1  0  0  0  0  1
  Masculin  2  1  1  2  0  2  4  0  1  1  1  1  0  3  1  1  1  0


J'ai voulu représenter la répartition en âge de mes patients, en indiquant également la répartition en âge par sexe. J'ai donc bricolé ça :

Code : Tout sélectionner

library(ggplot2)
p <- ggplot(data=top_patients, aes(x=2016-top_patients$an_naiss,  fill=Sexe))
p <- p + geom_histogram(binwidth=5, colour="black")
p <- p + theme_classic()
p
#ggsave(plot=p, file="select_38_agesexe.png")


Super, j'obtiens un histogramme où chaque barre compôrte 2 couleurs montrant la répartition homme/femme pour chaque classe d'âge.
Pour plus de clareté, j'ai voulu "splitter" les deux histogrammes "homme" et "femme" :

Code : Tout sélectionner

p <- p + facet_grid( . ~ Sexe)
p
#ggsave(plot=p, file="select_38_agesexe2.png")


Là tout parait bien, j'ai un histogramme des âges pour chaque sexe. Mais en y regardant de plus près, je constate des erreurs ! Les effectifs par tranche d'âge et par sexe ne correspondent pas aux données du tableau et du premier graphe...
Une erreur dans cette commande est-elle connue ? Ou ai-je manqué quelque chose ?


Merci d'avance !

Retourner vers « Questions en cours »

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 1 invité

cron