[RESOLU] mtext expression paste UTF8

Postez ici vos questions, réponses, commentaires ou suggestions - Les sujets seront ultérieurement répartis dans les archives par les modérateurs

Modérateur : Groupe des modérateurs

Dominique Soudant
Messages : 751
Enregistré le : 23 Avr 2008, 11:12
Contact :

[RESOLU] mtext expression paste UTF8

Messagepar Dominique Soudant » 07 Juin 2018, 16:21

Bonjour,
Ça :

Code : Tout sélectionner

mtext(expression("P"[90]~" chlorophylle" ~ italic(a)~" ("*symbol("m")*"g/L)")
      ,side = 2
      ,line = 2
      )
ça marche mais pour écrire Azote inorganique dissous (µmol/L) normalisé à 33 de salinité :

Code : Tout sélectionner

mtext(expression(paste("Azote inorganique dissous"~ "("*symbol("m"),"mol/L) normalisé à 33 de salinité"))
      ,side = 1
      ,line = 3
      )
ça ne marche pas, les accents génèrent des trucs étranges, ça sent la grouille utf8, windows-1252.
J'ai pas besoin habituellement de faire mes labels aussi proprement, du coup je ne comprends pas bien le fonctionnement de cette syntaxe et il n'y pas beaucoup d'aide pour les non anglo saxons, pour nos pb d'accents. Je repars dans ma recherche mais toute aide (voire soluce) est la bienvenue.
@+
DS

EDIT : le code que je vous ai mis vient de marcher ... Je ne sais pas pourquoi ça ne marchait pas, je ne sais pas pourquoi ça marche maintenant ... mais si ça marche c'est scientifique (proverbe shadock).

Retourner vers « Questions en cours »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité