installation x12 impossible

Postez ici vos questions, réponses, commentaires ou suggestions - Les sujets seront ultérieurement répartis dans les archives par les modérateurs

Modérateur : Groupe des modérateurs

samuel triviere
Messages : 14
Enregistré le : 26 Mai 2016, 11:04

installation x12 impossible

Messagepar samuel triviere » 31 Jan 2019, 16:22

Bonjour,

nous utilisons des serveur rstudio (1.1.453 / 1.0.153) et des versions de R 3.3.3 / 3.4.4 sur debian 8

Un utilisateur tente le package x12 (version 1.9.0). L'installation ne se fait pas,
le message n'est pas suffisamment explicite pour moi

install.packages('x12')
Installation du package dans ‘/home/AD/w1cswc/R/x86_64-pc-linux-gnu-library/3.4’
(car ‘lib’ n'est pas spécifié)
essai de l'URL 'http://X.X.X/logiciels/R/3.4/src/contrib/x12_1.9.0.tar.gz'
Content type 'application/x-gzip' length 157175 bytes (153 KB)
==================================================
downloaded 153 KB

* installing *source* package ‘x12’ ...
** package ‘x12’ correctement décompressé et sommes MD5 vérifiées
** R
** data
*** moving datasets to lazyload DB
** inst
** byte-compile and prepare package for lazy loading
** help
*** installing help indices
** building package indices
** testing if installed package can be loaded
Error: package or namespace load failed for ‘x12’:
.onAttach failed in attachNamespace() for 'x12', details:
call: if (!file.exists(path)) stop(paste(path, " - does not exists.",
error: l'argument est de longueur nulle
Erreur : le chargement a échoué
Exécution arrêtée
ERROR: loading failed
* removing ‘/home/AD/w1cswc/R/x86_64-pc-linux-gnu-library/3.4/x12’

Les packages source téléchargés sont dans
‘/tmp/Rtmpa96hDd/downloaded_packages’
Warning message:
In install.packages("x12") :
l'installation du package ‘x12’ a eu un statut de sortie non nul>


est-ce que vous auriez une idée sur l'erreur de chargement ?

merci,

cordialement,


samuel

Mickael Canouil
Messages : 484
Enregistré le : 04 Avr 2011, 08:53
Contact :

Re: installation x12 impossible

Messagepar Mickael Canouil » 01 Fév 2019, 13:14

Bonjour,

les prérequis sont-ils bien respectés?
En allant sur la page du package: https://cran.r-project.org/package=x12, il est indiqué dans le README:
The R package x12 is used in combination with the X-12 ARIMA/X13-ARIMA-SEATS Seasonal Adjustment Program.

By default (since version 1.7.0) the x13binary R package is used to provide the binaries.

But a local/alternative version could also be used which can be downloaded from https://www.census.gov/srd/www/x13as/ for Windows, Linux and as Source Code. After the installation the x13as.exe or the x13as executable should be on your system. The path to the executable is important it is set with the function x12path, e.g., x12path(“d:/X12InstallationPath/x13as.exe”) or x12path(“/usr/bin/x13a”).

X-13ARIMA-SEATS (http://www.census.gov/srd/www/x13as/) is the current version of the seasonal adjustment program of the US Census Bureau, it can also be used in connection with the R package x12, but at the moment the SEATS Spec is not included in the package at the moment, it is planned to include it in a future release.

On Mac OS X and Linux it is possible to compile x12a or x13as, the Makefile template ‘makefile.lnx’ has to be adapted and copied to Makefile afterwards ‘make’ should work to create the exexcutables.


Si c'est bien le cas, il est possible que l'installation ait été corrompu (installation interrompue par exemple).
Dans ce cas, il convient de le réinstaller.

Code : Tout sélectionner

remove.packages("x12")
install.packages("x12")


Cordialement,
Mickaël


Retourner vers « Questions en cours »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité