faire fonctionner x11

Postez ici vos questions, réponses, commentaires ou suggestions - Les sujets seront ultérieurement répartis dans les archives par les modérateurs

Modérateur : Groupe des modérateurs

samuel triviere
Messages : 14
Enregistré le : 26 Mai 2016, 11:04

faire fonctionner x11

Messagepar samuel triviere » 03 Déc 2018, 10:40

Bonjour,

j'utilise R3.4.4 et rstudio 1.1.453 sur debian 8 et j'ai un problème avec la fonction x11

Si j'ouvre R en ssh (avec mobaxterm), x11() fonctionne
la commande capabilities() mentionne "true" pour x11

Par contre, si je vais sur cette machine en http avec rstudio, x11() ne fonctionne pas, que ce soit dans la console ou en ouvrant R sur le terminal de rstudio.
la commande capabilities() mentionne "false" pour x11

Est-ce que quelqu'un a été confronté à cette difficulté et à réussi à la résoudre ?

merci à vous,

samuel

Serge Rapenne
Messages : 1300
Enregistré le : 20 Aoû 2007, 15:17
Contact :

Re: faire fonctionner x11

Messagepar Serge Rapenne » 03 Déc 2018, 11:33

Bonjour qd tu dis :
si je vais sur cette machine en http avec rstudio,

s'agit t'il de Rstudio server ? Si c'est le cas : https://support.rstudio.com/hc/en-us/community/posts/200659267-X11-and-RStudio-Server indique :
This won't work actually and you won't be able to open an external graphics device on the web client.


Serge

samuel triviere
Messages : 14
Enregistré le : 26 Mai 2016, 11:04

Re: faire fonctionner x11

Messagepar samuel triviere » 13 Déc 2018, 15:34

Bonjour,

merci pour votre retour.

En fait, je ne sais pas si c'est x11 qui pose problème car l'incident vient d'un utilisateur qui voulait afficher l'application shiny exemple (runExample("01_hello")). Et le graphique de cette appli ne s'affiche pas et produit le message d'erreur :
Error X11 : indisponible

Il semblerait que ce message d'erreur soit une fausse piste et que c'est la fonction cairo qui manque. C'est arrivé sur une version compilée de R (3.3.3). Sur la version R3.4.4 installée par paquet (apt-get install r-base ...) récupérés sur le site du cran, ça marche très bien.

Je pense que c'est dans ma commande de compilation ./configure qui manque un paramètre :

Code : Tout sélectionner

./configure --with-x=no --prefix=/opt/R/3.3.3 --enable-R-shlib

j'ai ajouté

Code : Tout sélectionner

--with-cairo=yes

mais sans succès.
Avez-vous une idée ?

cordialement,

samuel triviere


Retourner vers « Questions en cours »

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot], Google [Bot] et 1 invité