Charger package

Postez ici vos questions, réponses, commentaires ou suggestions - Les sujets seront ultérieurement répartis dans les archives par les modérateurs

Modérateur : Groupe des modérateurs

Arnaud Bellec
Messages : 4
Enregistré le : 14 Mai 2012, 13:48

Charger package

Messagepar Arnaud Bellec » 01 Juin 2012, 14:31

Bonjour,
Pouvez-vous me renseigner sur un point concernant les packages? Je suis novice sous R et je rencontre quelques difficultés...

Suite à des contraintes logiciel je doit utiliser la version 2.11.1 de R (sous windows7) avec les package suivants :
- adehabitat
- rgdal
- gpclib
- shapefiles

L'emploi de cette ligne pour charger adehabitat :

Code : Tout sélectionner

install.packages("adehabitat",dep=TRUE)

me renvoie une l'erreur suivante :

Erreur dans read.dcf(file = tmpf) :
La ligne commençant par '<!DOCTYPE html PUBLI...' est incorrecte !


J'ai donc tenté de charger "manuellement" le package en téléchargent le fichier.zip approprié sur le site de CRAN.
Après l'instalation j'obtiens le message suivant :
utils:::menuInstallLocal()
le package 'adehabitat' a été décompressé et les sommes MD5 ont été vérifiées avec succés

Mais lorsque je veux l'appeler avec la commande :

Code : Tout sélectionner

library(adehabitat)

Un message d'erreur apparait :
Error in library.dynam(lib, package, package.lib) :
la librairie partagée 'adehabitat' est introuvable
De plus : Message d'avis :
le package 'adehabitat' a été compilé avec la version R 2.15.0
Erreur : le chargement du package / espace de noms a échoué pour 'adehabitat'



Si j'ai bien compris je doit disposer de la version 2.15 pour utiliser ce package. Y a -t-il une solution pour charger et utiliser ce package (ainsi que les trois autres) avec la version 2.11.1?

Sur le site CRAN de "vieilles" version sont disponible, mais sous un format de compression en .deb. Est ce que je peut utiliser ces "vieilles" versions en les décompressant puis en les re-compressant en .zip pour pouvoir les installer par la suite?

J'espère avoir été compréhensible et vous demande de m'excuser si la solution à mon problème est évidente et vous fait perdre du temps en y répondant.

Cordialement.

Navarre Julien
Messages : 367
Enregistré le : 20 Avr 2012, 08:27

Messagepar Navarre Julien » 01 Juin 2012, 15:02

Salut,

pour ce qui est du message d'erreur
"De plus : Message d'avis :
le package 'adehabitat' a été compilé avec la version R 2.15.0"

D'après mon expérience, c'est un message qui s'affiche quand 2 versions de R sont installées sur ton ordi, quand tu charges un package avec la version la plus ancienne il serait à priori compilé avec la version la plus récente installé sur ton ordi.
Pas besoin d'avoir R 2.15 donc, mais pourtant il semble que tu l'aurai sur ta machine !

En ce qui concerne l'installation du package, elle s'est bien passée chez moi, j'ai installé manuellement à partir d'un zip. Et tu as besoin d'installer les packages ade4, tkrplot et shapefiles pour pouvoir charger adehabitat.
Peut être que ça peut changer quelque chose si tu ne l'as pas fait :x
Je ne sais pas trop d'où vient ton problème sinon...

Arnaud Bellec
Messages : 4
Enregistré le : 14 Mai 2012, 13:48

Messagepar Arnaud Bellec » 03 Juin 2012, 08:09

Bonjour,

Effectivement, R 2.15.0 était présent sur le PC.
Je l'ai donc désinstallé, et supprimé l'ensemble des répertoires lié au programme. Néanmoins le problème reste présent ...

Et tu as besoin d'installer les packages ade4, tkrplot et shapefiles pour pouvoir charger adehabitat.
Oui, merci de le rappeler. J'ai bien récupéré l'ensemble des packages nécessaire à l’installation de adehabitat.

matthieu faron
Messages : 586
Enregistré le : 16 Fév 2011, 11:23

Messagepar matthieu faron » 04 Juin 2012, 01:15

Bonjour,

C'est un message d'avis donc ça n'arrête pas l’exécution c'est pas forcement embêtant si y'a pas trop de versions de différence sinon il peut y avoir des problèmes de compatibilité.

Vu la description de l'installation que tu nous a fait je pense pas que ça dépend des différentes versions de R que tu as d'installées sur ton ordinateur. Ca provient du fait que la version que utilises n'est pas la même que la version de la personne qui a compilé les packages.

En fait à partir du code du programme = la source des version binaires (que tu peux installer directement) sont mises à dispositions des utilisateurs pour différents système d'exploitation et pour différentes versions de R. Selon la popularité du package les versions binaires (qui prennent de la place) sont gardés plus ou moins longtemps, ... le tiens qui est assez peu utilisé n'est plus disponible pour 2.11. Deux solutions s'offrent à toi :
- upgrader en 2.15 (tu nous a dis que tu pouvais pas mais beaucoup de corrections ont été faites entre ces deux versions c'est dommage de pas en profiter). Pourquoi tu peux pas upgrader (je vois difficilement l’intérêt de garder une version potentiellement buggé dans un projet professionnel).
- compiler toi même le package (c'est à dire faire le travail qui est fait sur le site toi même). Il faut donc que tu télécharge la source en .tar.gz ainsi que différents programmes (compilateur c etc... ) puis lancer la compilation en ligne de commande ....Le package sera donc adapté à ton système, ça fait un peu peur pour un débutant mais en suivant tous les conseils de la documentation et dispo sur le forum ça finit par passer....

Les outils en question:
http://cran.r-project.org/bin/windows/Rtools/

Le plus chiant dans mon expérience est de modifier le PATH de windodws pour qu'il trouve tout seul les programmes.

Le pire c'est peut être que le problème vient peut être d'ailleurs...
Matthieu FARON

Arnaud Bellec
Messages : 4
Enregistré le : 14 Mai 2012, 13:48

Messagepar Arnaud Bellec » 04 Juin 2012, 07:06

Bonjour,
Concernant l'upgrade de R, je suis limité à la version 2.11 du fait de l'utilisation de R à travers un logiciel SIG (QGIS) et d'un pluggin (Home-Range Analyses). Voilà pourquoi je n'utilise pas la version 2.15.

Suite à tes conseil je vais regarder me pencher sur la compilation des packag, qui effectivement me fait un peu peur car je n'y connais pas grand chose.


Retourner vers « Questions en cours »

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 0 invité

cron